ERROR: While executing gem … (Zlib::BufError)

Problem:

Recently I was trying to update the rails gem (to rails 2.2 specifically). However, it threw an error everytime: ERROR: While executing gem … (Zlib::BufError).

Solution:

I’ve figured that the solution is to
1. gem update –system
2. gem install update_rubygems
3. update_rubygems

Advertisements